The Bat! Professional 8.4 Full Patch

By | 22 June 2018

The Bat! Professional 8.4 Full Patch is an e-mail application that supports multiple POP3 accounts, multithreading, MIME and UUencode standards, multimedia, APOP authorization, and PGP. You also will find a fast and comfortable message editor with text highlighting, as well as a mail dispatcher for managing messages on servers. English, Russian, German, Dutch, Polish, Swedish, Italian, Lithuanian, and Romanian interfaces are built in, as is a multilingual spelling checker. The application’s other features include automatic dial-up networking (configurable for multiple accounts) and the option to include a photo with each address-book entry. There also are enhancements, such as message coloring, flagging, advanced filtering, speed improvements, and virus protection.

Features :

  • PGP, GnuPG and S/MIME Support
  • Powerful Filtering System
  • Internal HTML Viewer Configurabe Image Retrieval
  • The Bat!’s own Address Book
  • Safe Handling of Attached Files
  • Handy Templates
  • Selective Message Download
  • RSS Feed Subscriptions

What’s New :
The Bat! 8.4 (22 June 2018)

New features

  • You can now use styles in the HTML editor
  • The Bat! now splits long IMAP commands (of about 7500 characters or more) into shorter ones. This is needed for IMAP servers (e.g. Zimbra) that don’t accept longer commands, e.g. when you move thousands of messages from one folder to another and the messages are not in a sequence. See “Long Command Lines” sections of the following RFCs for more details: RFC-2683, p. 3.2.1.5, RFC-7162, p. 4.
  • New command-line parameter “/TLS_VERSION_RANGE:0-3” to specify lowest and highest SSL/TLS version minor byte number that The Bat! should support. “0” means SSL 3.0, “1” means TLS 1.0, “2” means TLS 1.1 and “3” means “TLS 1.2”. For example, to disable SSL 3.0, use “/TLS_VERSION_RANGE:1-3”. Another example to only allow TLS 1.2 is “/TLS_VERSION_RANGE:3-3”
  • New command-line parameter “/TLS_DISABLE_PERFECT_FORWARD_SECRECY” to disable perfect forward secrecy
  • New command-line parameter /LOG_IA32CPUID to write list of CPU capabilities to the ex_log.txt file
  • New command-line parameter (must be specified as the first parameter in order to be accepted, other parameters may follow it): “/SHA1_BENCHMARK”. For example, you can run /SHA1_BENCHMARK /NOLOGO /LOG_IA32CPUID
  • New command-line parameter “/TEMP:” to specify a different temporary folder instead of one specified by %TEMP% environment variable
  • Support for “Intel SHA extensions” instructions for SHA-1 on CPUs that support it for hardware acceleration of SHA-1. These instructions are introduced on Intel Goldmont microarchitecture processors, e.g. Pentium J4205, Celeron J3455, Atom C3958, etc. These instructions are currently supported for 64-bit version of The Bat! only
  • Added the ‘Insert Symbol’ button to the editor toolbar
  • Added support for TLS Server Name Indication (SNI) Extension. It is useful when multiple servers are sharing the same IP address. For more information on SNI, see https://en.wikipedia.org/wiki/Server_Name_Indication
  • Added new path macros: %PROGRAMFILES% and %PROGRAMFILESX86%
  • (#0001454) Toolbar has now drop-down history for the “Copy to folder” and “Move to folder” buttons

Improvements

  • Updated HTML editor component version
  • The Bat! now tries to call the GetAddrInfoExW function instead of GetAddrInfoExA. Only if GetAddrInfoExW is not available, it falls back to GetAddrInfoExA
  • The Bat! is now able to locate GPG4WIN 3.1.1
  • Optimized CPU thread usage by creating and freeing threads less frequent because of using more threads with a reusable thread pool
  • If CPU supports SHA extensions, The Bat! will use them for SHA-256 hash. You can call The Bat! with /SHA256_BENCHMARK command line parameter to figure out whether you CPU supports the extension and what is real gain from using the extensions

Fixes

  • The Bat! didn’t notify plugins about a “MainWindowLoaded” event since version 8
  • Fixed the “Select Image” icon in toolbar customization
  • Some modifications on PGP internal signature verification
  • Some fatal errors that prevented The Bat! from starting and were silent now are displayed to the user
  • If external third-party plugins in The Bat! prevent it from starting successfully, The Bat! restarts, removes all the plugins from the list, and notifies the user about it, creating copies of plugin configuration files
  • If a Windows API function to resolve host name fails with an Access Violation error or other exception, The Bat! no longer uses that API function
  • Fixed splash screen labels’ transparency
  • Fixed some memory leaks
  • Fixed some “Access Violation” errors which could occur while working with IMAP
  • Fixed issue with showing some HTML entities (symbols)
  • Fixed editor toolbars
  • Fixed a bug in determining system-defined folders
  • Added Quick Templates combo on toolbar
  • (#0001496) Access Violation on closing The Bat! while viewing a message in the internal HTML viewer
  • (#0001493) Sub-filters didn’t correctly handle the “is” operator
  • (#0001482) Reintroduced: The Bat! v6.8.4 It’s not possible to save the changes in the “Insert Hyperlink” window (original issue 0000730)
  • (#0001481) Reintroduced: Embedded images in messages bodies grow in size on each reply on high DPI monitors (original issue 0001178)
  • (#0001478) Quick Reply is unusable – Access Violations upon trying to copy, cut, backspace, delete and paste a Quick Template
  • (#0001476) Added: the option “Clear formatting”, “IncreaseFont”, “DecreaseFont” to the HTML-editor
  • (#0001474) Added: the option for forwarding types to the drop-down of the “Forward” icon on the main toolbar
  • (#0001471) Fixed: clicking on the email of an account’s information page creates a message from the default account
  • (#0001466) Added buttons “Subscript” and “Superscript” to the HTML editor
  • (#0001463) Added the button “Strikethrough” to the HTML editor
  • (#0001461) The recipient’s name got corrupted in the editor window
  • (#0001460) Shift+Enter for Bullet Points was broken
  • (#0001415) Wrong “Created” date if “Date:” line is missing in the message headers
  • (#0000571) Open attachments with the Shift key pressed still displayed a warning
  • (#0000151) Could not load HTML images under 32-bit (many images with the same URL)

System Requirements :

  • Windows XP (32/64 bit)
  • Windows Vista (32/64 bit) – Certified for Windows Vista
  • Windows 7 (32/64 bit) – tested to meet Compatible with Windows® 7 requirements
  • Windows 8 (32/64 bit)
  • Windows 8.1 (32/64 bit)
  • Windows 10 (32/64 bit) – Certified for Windows 10
  • Windows Server 2003 & R2
  • Windows Server 2008 & R2
  • Windows Server 2012 & R2
  • Windows Server 2016 & R2

How to Activate Full Version :

1. Extract the downloaded file ( by right click > extract Here )
2. Install program
3. After Installation, don’t run the program (also close from system try icon at bottom right side)
4. Copy patch & paste to installation folder of the program
– ( Computer \ Disk C \ Program Files \ The Bat! )
5. Run Patch (by right click > Run as administrator)
6. Click patch and select thebat64.exe
7. Click keygen, then type username
8. Click generate then copy serial & use for activation
9. Done

Download Link

-> 32bit – The Bat! Professional 8.4 Full Patch (32.6 MB) | Via Filescdn

-> 64bit – The Bat! Professional 8.4 Full Patch (35.1 MB) | Via Filescdn

-> Patch Only (394 KB) | via Filescdn

-> 32bit – The Bat! Professional 8.4 Full Patch (32.6 MB) | Via Sendit

-> 64bit – The Bat! Professional 8.4 Full Patch (35.1 MB) | Via Sendit

-> Patch Only (394 KB) | via Sendit

<- Download Instruction | Click Here->

Share this post on :

Related Posts

Leave a Reply

Your email address will not be published. Required fields are marked *